Accelerator Update Instructions

Features & Improvements

  • Restful API Suite for Audiences, Campaigns and Shared Content Libraries. The beta documentation can be found here. The user name is ‘mgdocs’. The password is identical to this page’s password.
  • Improved Search Functionality
  • Various UI Performance Improvements when loading lists with lots of items
  • Various Bug Fixes

Client Browser Requirements

No changes to client browser requirements.

  • High Resolution Monitor (1280 x 800 or higher)
  • Apple Safari or Firefox
  • Flash (recommended, but not required)

Minimum System Requirements

No changes to minimum system requirements.

  • RHEL/CentOS 6.4 (64 bit)
  • Tomcat 8
  • MySQL 5.6
  • Java 1.8
  • 16GB RAM
  • 100GB Disk
  • 12 Core CPU
  • 1000Mbps internal network
  • 100Mbps up/down to the Internet
  • Outbound access to api.messagegears.net (AWS)
  • No inbound access from internet required
  • Dedicated server/virtual machine required for support

Upgrade Instructions

MessageGears Accelerator


# Requires Root Access. Run the following commands as the Root user.
# Stop Tomcat. "service tomcat8 stop"
# Run the MySQL Dump Command "mysqldump -u root --database accelerator > ~/accelerator_pre_2.0.1.sql"
# Remove the contents of "/usr/share/tomcat/webapps/"
# Remove the contents of "/usr/share/tomcat/work/"
# Remove the contents of "/usr/share/tomcat/temp/"
# Download the new WAR file from "https://messagegears-files.s3.amazonaws.com/accelerator-2.0.1.war" to "/usr/share/tomcat/webapps/
accel.war"
# Start Tomcat. "service tomcat8 start"

Supported Databases

The following databases and versions have been certified to work with Accelerator. Since Accelerator simply passes through the SQL that you provide, most other versions of these databases will work as well.

  • Teradata 14.0
  • MySQL 5.6.13
  • Oracle 11.2
  • SQL Server 11.0
  • Postgres 9.3.1
  • New: Snowflake
  • New: Hadoop (Hive)

JDBC Drivers used by Accelerator:

  • Teradata Type 4 JDBC Driver 14.10.00.17
  • MySQL JDBC Driver 5.1.21
  • Oracle JDBC Driver 12.1.0.1
  • Microsoft SQL Server Type 4 JDBC Driver 4.0.2206.100
  • Postgres JDBC Driver 9.1-901
  • IBM DB2 JDBC Driver 4.16.53
  • New: Snowflake JDBC 2.8.1
  • New: Hadoop (Hive) 0.13.1